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Excel- Working with Formulae 

Excel is one of the most powerful ways to automate calculations and analyze data.  

Basics of Excel Formulae 

• Start with = → Every formula begins with an equals sign. 

• Operators:  

o + (addition), - (subtraction), * (multiplication), / (division) 

o ^ (exponentiation, e.g., =2^3 gives 8) 

• Cell References:  

o A1 → refers to the value in cell A1 

o $A$1 → absolute reference (doesn’t change when copied) 

o A$1 or $A1 → mixed references 

 
Commonly Used Functions 

Function Example Purpose 

SUM =SUM(A1:A10) Adds values in a range 

AVERAGE =AVERAGE(B1:B5) Finds mean 

IF =IF(C1>50,"Pass","Fail") Conditional logic 

VLOOKUP =VLOOKUP(101,A2:D20,3,FALSE) Searches vertically 

HLOOKUP =HLOOKUP(101,A2:D20,3,FALSE) Searches horizontally 

INDEX + MATCH =INDEX(B2:B10,MATCH(50,A2:A10,0)) Flexible lookup 

LEN =LEN(A1) Counts characters in text 

CONCAT / & =A1&B1 Joins text 

 

AutoSum 

The AutoSum feature in Excel is one of the quickest ways to add up numbers without 

manually typing a formula.  

   Using AutoSum Step by Step 

1. Select the cell where you want the result to appear. 

2. Go to the Home tab (or the Formulas tab) on the Ribbon. 

3. Click the AutoSum (Σ) button. 

4. Press Enter to confirm. 
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Spreadsheet  

A spreadsheet is essentially a digital grid made up of rows and columns, where you can 

organize, calculate, and analyze data. Excel is the most widely used spreadsheet program, but 

the same concepts apply to Google Sheets and others.  

Structure of a Spreadsheet 

• Rows → Horizontal lines, numbered (1, 2, 3…). 

• Columns → Vertical lines, labeled (A, B, C…). 

• Cells → The intersection of a row and column (e.g., A1, B2). 

• Worksheets → Individual pages within a spreadsheet file. 

What You Can Do in a Spreadsheet 

• Data Entry: Store text, numbers, dates, or formulas. 

• Calculations: Use formulas like =SUM(A1:A10) or =AVERAGE(B1:B5). 

• Formatting: Change font, color, borders, and number formats. 

• Charts & Graphs: Visualize data with bar charts, pie charts, line graphs. 

• Sorting & Filtering: Organize data by values or conditions. 

• PivotTables: Summarize and analyze large datasets quickly. 

AutoFill 

AutoFill in Excel is a feature that helps you quickly copy formulas, values, or create 

sequences without typing everything manually. It saves a lot of time when working with 

repetitive data. 

How AutoFill Works 

1. Enter a value or formula in a cell. 

2. Place your mouse over the small square (fill handle) at the bottom-right corner of the 

cell. 

3. Drag the handle across rows or columns. 

4. Excel will automatically:  

o Copy the formula or value. 

o Extend a series (numbers, dates, days of the week). 

o Adjust cell references if needed. 

Fill handle  

The fill handle in Excel is that tiny square at the bottom-right corner of a selected cell or 

range. It’s one of the most useful tools for speeding up repetitive tasks. 

What the Fill Handle Does 

• Copy values or formulas → Dragging the fill handle copies the content into adjacent 

cells. 

• Extend series → It can automatically continue sequences (numbers, dates, days, 

months). 

• Adjust formulas → When dragging formulas, Excel updates cell references (relative 

referencing). 

• Apply formatting → It can also copy formatting along with values. 
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Excel Short Questions with Answers 

Question Answer 

1. What is the purpose of the AutoSum 

button? 

It quickly inserts a SUM formula to add a 

range of numbers. 

2. Define a cell reference. 
It identifies a cell by its column letter and 

row number (e.g., A1). 

3. Differentiate between relative and 

absolute references. 

Relative changes when copied (A1 → 

A2), absolute stays fixed ($A$1). 

4. What does =AVERAGE(A1:A10) 

calculate? 

The mean of values in cells A1 through 

A10. 

5. Which function finds the largest value 

in a range? 
MAX(range) 

6. What is the role of the fill handle? 
It copies values/formulas or extends series 

when dragged. 

7. Write the formula to total cells B2 to 

B6. 
=SUM(B2:B6) 

8. Difference between COUNT and 

COUNTA? 

COUNT counts numbers only, COUNTA 

counts all non-empty cells. 

9. How do you insert a chart in Excel? 
Select data → Insert tab → Choose chart 

type. 

10. What does 

=IF(C2>=40,"Pass","Fail") do? 

Returns “Pass” if C2 ≥ 40, otherwise 

“Fail”. 

 

 
MCQs on Excel 

1. What does the AutoSum button do? 

a. Finds the average of numbers 

b. Adds up a range of numbers 

c. Counts the number of cells 

d. Finds the maximum value Answer: b) Adds up a range of numbers 

2. Which function returns the smallest number in a range? 

a. SUM 

b. MIN 

c. MAX 

d. COUNT       Answer: b) MIN 

3. What is the shortcut for AutoSum in Excel? 

a. Ctrl + S 

b. Alt + = 

c. Ctrl + = 

d. Shift + =      Answer: b) Alt + = 

 



Page 4 of 8 
 

4. Which of the following is an absolute cell reference? 

a. A1 

b. $A$1 

c. A$1 

d. $A1       Answer: b) $A$1 

5. What does the formula =IF(B2>=50,"Pass","Fail") return if B2 = 45? 

a. Pass 

b. Fail 

c. Error 

d. 45       Answer: b) Fail 

6. Which function is used to count only numeric values in a range? 

a. COUNTA 

b. COUNT 

c. COUNTIF 

d. SUM       Answer: b) COUNT 

7. Which feature allows you to copy formulas or extend series by dragging? 

a. AutoSum 

b. Fill Handle 

c. PivotTable 

d. Data Validation     Answer: b) Fill Handle 

8. Which chart type is best for showing proportions? 

a. Line chart 

b. Bar chart 

c. Pie chart 

d. Column chart      Answer: c) Pie chart 

9. What does the function =LEN("Excel") return? 

a. 4 

b. 5 

c. 6 

d. Error        Answer: b) 5 

More Excel MCQs 

1. Which function is used to join text from different cells? 

a. CONCAT / & 

b. SUM 

c. TEXTJOIN 

d. LEN 

Answer: a) CONCAT / & (also TEXTJOIN in newer versions) 

2. What does the LEN function return? 

a. Length of a number 

b. Number of characters in a text string 

c. Number of cells in a range 

d. Largest value in a range 

Answer: b) Number of characters in a text string 

3. Which feature allows you to restrict data entry to specific values? 

a. Data Validation 

b. Conditional Formatting 

c. Filter 

d. Sort 

Answer: a) Data Validation 
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4. Which chart type is best for showing trends over time? 

a. Pie Chart 

b. Line Chart 

c. Column Chart 

d. Bar Chart     Answer: b) Line Chart 

5. What does the VLOOKUP function do? 

a. Looks up values horizontally in a table 

b. Looks up values vertically in a table 

c. Returns the maximum value in a range 

d. Counts the number of values in a range 

Answer: b) Looks up values vertically in a table 

6. Which shortcut saves the current workbook? 

a. Ctrl + S 

b. Ctrl + C 

c. Ctrl + V 

d. Ctrl + P     Answer: a) Ctrl + S 

7. Which function returns the current date? 

a. TODAY() 

b. NOW() 

c. DATE() 

d. TIME() Answer: a) TODAY() (NOW() returns date + time) 

8. Which feature highlights cells based on rules (e.g., marks < 40)? 

a. Conditional Formatting 

b. Data Validation 

c. Filter 

d. Sort    Answer: a) Conditional Formatting 

9. Which function counts all non-empty cells in a range? 

a. COUNT 

b. COUNTA 

c. COUNTIF 

d. SUM      Answer: b) COUNTA 

10. Which tab contains options for inserting charts? 

a. Home 

b. Data 

c. Insert 

d. Review      Answer: c) Insert 
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Matching  

Concept (Column A) Definition (Column B) 

AutoSum Inserts a SUM formula to add numbers automatically 

Cell Reference Identifies a cell by column and row (e.g., A1) 

Fill Handle Small square used to copy formulas or extend series 

MAX Function Returns the largest value in a range 

IF Function Performs conditional logic (e.g., Pass/Fail) 

Chart Creates a visual representation of data 

COUNT Function Counts numeric values in a range 

Absolute Reference A fixed reference that doesn’t change ($A$1) 

AVERAGE Function Calculates the mean of values in a range 

PivotTable Summarizes and analyzes large datasets quickly 

 
True/False  

Question Answer 

Every formula in Excel must begin with =. True 

The AutoSum button can only calculate 
totals, not averages. 

False (it can also do Average, Min, Max, Count via 
dropdown) 

A cell reference like $A$1 is an absolute 
reference. 

True 

The Fill Handle is used to copy formulas or 
extend series. 

True 

The MAX function returns the smallest value 
in a range. 

False (it returns the largest value) 

The COUNT function counts all non-empty 
cells, including text. 

False (COUNT counts numbers only; COUNTA 
counts all non-empty cells) 

Charts in Excel are used to visually represent 
data. 

True 

The IF function can be used for conditional 
logic (e.g., Pass/Fail). 

True 

PivotTables are used to summarize and 
analyze large datasets. 

True 

The shortcut Alt + = is used for AutoSum. True 
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Fill in the Blanks 

1. Every formula in Excel must begin with _____. 

Answer: = 

2. The button used to quickly add a range of numbers is called _____. 

Answer: AutoSum 

3. A cell reference that does not change when copied is called an _____ reference. 

Answer: Absolute 

4. The function used to calculate the average of a range is _____. 

Answer: AVERAGE 

5. The small square at the bottom-right corner of a cell used to copy formulas or extend 

series is called the _____. 

Answer: Fill Handle 

6. The function that returns the largest value in a range is _____. 

Answer: MAX 

7. To count only numeric values in a range, we use the _____ function. 

Answer: COUNT 

8. To visually represent data, Excel uses _____. 

Answer: Charts 

9. The function =IF(A1>=40,"Pass","Fail") is an example of a _____ function. 

Answer: IF (conditional) 

10. A tool used to summarize and analyze large datasets in Excel is called a _____. 

Answer: PivotTable 

How to Filter Data 

1. Select your dataset → Click any cell inside the table or range. 

2. Enable Filter → Go to the Data tab → click Filter.  

o Small drop-down arrows will appear in the column headers. 

3. Apply a Filter:  

o Click the arrow in the column you want to filter. 

o Uncheck Select All and choose the values you want to display. 

o Click OK → Only matching rows remain visible. 

4. Clear Filter:  

o Go to Data tab → Clear to remove the filter but keep arrows. 

o Click Filter again to remove arrows completely. 

 

IF function 

The IF function in Excel is used to test a condition and return one value if the condition is 

TRUE, and another if it is FALSE. Its basic syntax is =IF(logical_test, value_if_true, 

value_if_false). This makes it one of the most powerful tools for logical decision-making 

in spreadsheets. 

Syntax and Arguments 

• Formula: =IF(logical_test, value_if_true, value_if_false) 

• Arguments:  

o logical_test (required): The condition you want to check (e.g., A1>50). 

o value_if_true (optional): The result if the condition is TRUE. 

o value_if_false (optional): The result if the condition is FALSE. 
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Common Examples 

1. Basic IF 

o Formula: =IF(B2>500,"High","Low") 

o Meaning: If the value in B2 is greater than 500, return “High”; otherwise, 

return “Low”. 

2. Empty Cell Handling 

o Formula: =IF(C2="","Not Entered","Entered") 

o Meaning: If C2 is blank, return “Not Entered”; otherwise, “Entered”. 

3. Pass/Fail Example 

o Formula: =IF(D2>=40,"Pass","Fail") 

o Meaning: If the score in D2 is 40 or more, return “Pass”; otherwise, “Fail”. 

 

Fill in the blanks. 

1. The currently selected cell is known as the active cell. 

2. The Product function is used to get the product of all numbers in a range. 

3. The AutoFill feature lets us quickly fill a logical series of numbers, labels or formulae. 

4. To quickly add numbers in a range, use the AutoSum feature. 

5. Formulae always begin with an equal sign. 

6. The Max function return returns the largest value in a set of numbers. 

7. The Sort & Filter group is present in the Data tab. 

 

 

True/False  

 

1. To add all the marks in a range of cells, give the formula: =ADD (A1..A2). False 

2. The COUNT ( ) function works only with numeric values. True 

3. To find the average value, we use the AVG ( ) function. True 

4. Formulae are case – sensitive. False 

5. A workbook can have only two worksheets. False 

6. It is possible to do calculations with text data. False 

7. You cannot sort textual data. False 

8. Functions are built in formulae. True 

9. A worksheet is a matrix of rows and columns. True 

10. Functions like COUNT( ), SUM( ), AVERAGE ( ), can be added in a worksheet by clicking the 

AutoSum button. True 

 


